mac:errors:xcodebuild

Xcode

$ brew install qt
Xcode not set up properly. You may need to confirm the license agreement by running /usr/bin/xcodebuild.

There is a similar problem with building Qt itself with Xcode 8. I have the Qt 5.7 source code on my machine with Xcode 8 GM, and I when I run 'configure' I get the same message about needing to agree to the Xcode license. Going through the agree procedure (which is described wrongly in the error message, incidentally) makes no difference. (https://forum.qt.io/topic/71119/project-error-xcode-not-set-up-properly/7)

<Growl/Growl.h> file not found in xcode
To include a framework in your Xcode project, choose Project > Add to Project and select the framework directory. Alternatively, you can control-click your project group and choose Add Files > Existing Frameworks from the contextual menu. When you add an existing framework to your project, Xcode asks you to associate it with one or more targets in your project. Once associated, Xcode automatically links the framework against the resulting executable.
xcode-select: error: tool 'xcodebuild' requires Xcode
xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance
$ xcode-select --install
$ xcode-select --switch /Library/Developer/CommandLineTools
$ xcode-select -s /Applications/Xcode.app/Contents/Developer
  • mac/errors/xcodebuild.txt
  • Последнее изменение: 2018/02/21 03:51
  • mirocow