Routers/Маршрутизаторы

RTN-66U

A5004NS

Проброс портов на маршрутизаторах Mikrotik

Из команднной строки

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.2.2 protocol=udp in-interface=pptp-out-anonine dst-port=9999

Через интерфейс

Выбираем в меню IP/Firewal, переходим на вкладку NAT и в открывшемся окне добавляем новое правило (кнопка +)

Затем добавляем фильтр условия, где 192.168.1.123 (внешний IP адресс)

Затем добавляем действие, где 192.168.2.2 (внутренний IP адресс)

Action

  • accept — Просто принимает пакет;
  • add-dst-to-address-list — Добавляет адрес назначения в указанный список адресов;
  • add-src-to-address-list — Аналогично предыдущему, но для исходного адреса;
  • dst-nat — Переадресовывает данные, пришедшие из внешней сети, во внутреннюю;
  • jump — Позволяет применить для данных правила из другой цепочки. Например, для цепочки srcnat — применить правила цепочки dstnat;
  • log — Просто добавляет информацию о пакете в лог роутера;
  • masquerade — Тот самый «Маскарад»: подмена внутреннего адреса машины из локальной сети на адрес роутера;
  • netmap — Отображение одного адреса на другой. Фактически, развитие dst-nat;
  • passthrough — Пропуск текущего пункта правил и переход к следующему. Используется в основном для статистики;
  • redirect — Перенаправляет данные на другой порт в пределах роутера;
  • return — Возвращает управление обратно, если в эту цепочку выполнялся прыжок правилом jump;
  • same — применяется в очень редких случаях, когда нужно применять одни и те-же правила для группы адресов;
  • src-nat — Обратная dst-nat операция: перенаправление данных из внутренней сети во внешнюю.

Sniffer/Прослушка трафика

Для запуска сниффера и организации стриминга необходимо в терминале выполнить ниже следующии команды.

  • /tool sniffer set streaming-enabled=yes streaming-server=192.168.2.2
  • /tool sniffer start

или запустить из Tools/Packet Sniffer

где 192.168.2.2 машина на которой запущен Wireshark с параметрами Capture filter: udp port 37008

Как настроить iptv?

/routing igmp-proxy interface add alternative-subnets=0.0.0.0/0 disabled=no interface=pppoe-mgts-uplink threshold=1 upstream=yes
/routing igmp-proxy interface add disabled=no interface=bridge threshold=1 upstream=no

Как настроить upnp?

Как настроить VPN?

PPTP

Плюсы: клиент PPTP встроен почти во все операционные системы очень прост в настройке работает быстро

Минусы: небезопасен (уязвимый протокол аутентификации MS-CHAP v.2 все еще много где используется)

не надежен

L2TP/IPSec

Плюсы: очень безопасен легко настраивается доступен в современных операционных системах

Минусы: работает медленнее, чем OpenVPN может потребоваться дополнительная настройка роутера

Использует порты TCP/UDP 1701

OpenVPN

Плюсы: гибко настраивается очень безопасен (зависит от выбранного алгоритма шифрования, но все они безопасны) может работать сквозь файрволлы может использовать широкий спектр алгоритмов шифрования

Минусы: необходимо стороннее программное обеспечение может быть неудобен в настройке ограниченная поддержка портативными устройствами

/ip upnp set allow-disable-external-interface=no enabled=yes show-dummy-rule=yes
/ip upnp add disabled=no interface=bridge type=internal
/ip upnp add disabled=no interface=pppoe-mgts type=external
Создание сертификатов

Создаем шаблон

/certificate add name=cert1 common-name=host.foo.bar key-size=2048 country=XX state=MyState locality=MyCity organization=foo.bar subject-alt-name=email:user@foo.bar

Создаем сертификат

/certificate create-certificate-request
template: cert1
key-passphrase: ********

Импотрируе сертификаты

/certificate import
passphrase: ********
     certificates-imported: 1
     private-keys-imported: 1
            files-imported: 2
       decryption-failures: 0
  keys-with-no-certificate: 0

Проверяем наличие сертификата

/certificate print detail

Ссылки/Статьи

Видео

Скрипты