IDE ZeroBrane Studio

$ cd /Users/relvin/Downloads/ZeroBraneStudio-1.40
$ DYLD_LIBRARY_PATH=bin bin/lua.app/Contents/MacOS/lua src/main.lua

nano /Applications/ZeroBraneStudio.app/Contents/ZeroBraneStudio/cfg/user-sample.lua

--[[--
  Use this file to specify **User** preferences.
  Review [examples](+/Applications/ZeroBraneStudio.app/Contents/ZeroBraneStudio/cfg/user-sample.lua) or check [online documentation](http://studio.zerobrane.com/documentation.html) for details.
--]]--
 
activateoutput = true
allowinteractivescript = true
commandlinehistorylength = 10
filehistorylength = 20
language = "en"
showhiddenfiles = false
showmemoryusage = true
singleinstance = true
 
debugger.allowediting = true
debugger.hostname = "localhost"
debugger.linetobreakpoint = false
debugger.maxdatalength = 400
debugger.maxdatanum = 400
debugger.maxdatalevel = 10
debugger.requestattention = true
debugger.runonstart = false
 
path.lua = '/usr/local/bin/lua'
path.lua52 = '/usr/local/bin/lua5.2'
path.lua53 = '/usr/local/bin/lua5.3'
path.love2d = '/Applications/love.app/Contents/MacOS/love'
 
excludelist = {
".svn/", ".git/", ".hg/", "CVS/", "*.pyc", "*.pyo", "*.exe", "*.dll", "*.obj","*.o", "*.a", "*.lib", "*.so", "*.dylib", "*.ncb", "*.sdf", "*.suo", "*.pdb", "*.idb", ".DS_Store", "*.class", "*.psd", "*.db"
}
binarylist = {
"*.jpg", "*.jpeg", "*.png", "*.gif", "*.ttf", "*.tga", "*.dds", "*.ico", "*.eot", "*.pdf", "*.swf", "*.jar", "*.zip", ".gz", ".rar"
}
 
local xcode = {
-- File menu
  [ID.NEW]              = "Ctrl-N",
  [ID.OPEN]             = "Ctrl-O",
  [ID.CLOSE]            = "Ctrl-W",
  [ID.SAVE]             = "Ctrl-S",
  [ID.SAVEAS]           = "Shift-Ctrl-S",
  [ID.SAVEALL]          = "Alt-Ctrl-S",
  [ID.RECENTFILES]      = "",
  [ID.EXIT]             = "Ctrl-Q",
-- Edit menu
  [ID.CUT]              = "Ctrl-X",
  [ID.COPY]             = "Ctrl-C",
  [ID.PASTE]            = "Ctrl-V",
  [ID.SELECTALL]        = "Ctrl-A",
  [ID.UNDO]             = "Ctrl-Z",
  [ID.REDO]             = "Shift-Ctrl-Z",
  [ID.SHOWTOOLTIP]      = "Ctrl-T",
  [ID.AUTOCOMPLETE]     = "Ctrl-K",
  [ID.AUTOCOMPLETEENABLE] = "",
  [ID.COMMENT]          = "Ctrl-U",
  [ID.FOLD]             = "F7",
  [ID.CLEARDYNAMICWORDS] = "",
-- Search menu
  [ID.FIND]             = "Ctrl-F",
  [ID.FINDNEXT]         = "Ctrl-G",
  [ID.FINDPREV]         = "Shift-Ctrl-G",
  [ID.REPLACE]          = "Ctrl-R",
  [ID.FINDINFILES]      = "Shift-Ctrl-F",
  [ID.REPLACEINFILES]   = "Shift-Ctrl-R",
  [ID.SORT]             = "",
-- View menu
  [ID.VIEWFILETREE]     = "Shift-Ctrl-P",
  [ID.VIEWOUTPUT]       = "Shift-Ctrl-O",
  [ID.VIEWWATCHWINDOW]  = "Shift-Ctrl-W",
  [ID.VIEWCALLSTACK]    = "Shift-Ctrl-S",
  [ID.VIEWDEFAULTLAYOUT] = "",
  [ID.VIEWFULLSCREEN]   = "Shift-Ctrl-A",
-- Project menu
  [ID.RUN]              = "F5",
  [ID.RUNNOW]           = "Shift-Ctrl-R",
  [ID.COMPILE]          = "Ctrl-B",
  [ID.ANALYZE]          = "Shift-Ctrl-B",
  [ID.STARTDEBUG]       = "F9",
  [ID.ATTACHDEBUG]      = "Shift-F9",
-- Debug
  [ID.STOPDEBUG]        = "Ctrl-.",
  [ID.STEP]             = "F12",
  [ID.STEPOVER]         = "F10",
  [ID.STEPOUT]          = "F11",
  [ID.TRACE]            = "",
-- Breakpoints
  [ID.BREAK]            = "Ctrl-B",
  [ID.BREAKPOINTTOGGLE] = "Ctrl-\\",
  [ID.CLEAROUTPUT]      = "",
 
  [ID.INTERPRETER]      = "",
  [ID.PROJECTDIR]       = "",
-- Help menu
  [ID.ABOUT]            = "F1",
-- Watch window menu items
  [ID.ADDWATCH]         = "Ins",
  [ID.EDITWATCH]        = "F2",
  [ID.DELETEWATCH]      = "Del",
-- Editor popup menu items
  [ID.QUICKADDWATCH]    = "",
  [ID.QUICKEVAL]        = "",
}
 
local G = ...
for id, key in G.pairs(xcode) do keymap[id] = key end

Подробнее...